Инсталляция СО

 Top

Процесс инсталляции программы "Спортивное ориентирование" третьей версии не для всех пользователей может быть интуитивно понятной, поэтому автор программы предлагает небольшую справку, которая поможет этот процесс сделать легким и приятным. Поскольку вариантов инсталляции есть несколько, в справке будет описан самый полный.

Перед установкой убедитесь, что Вы вошли с правами администратора. Итак у Вас есть файл Setup_SO_Full.exe, или что то на вроде этого. Для начала делаем двойной "клик", жмем "Дальше", читаем (или просто принимаем) лицензионное соглашение, жмем Enter (или мышкой на "Согласен") и терпеливо ждем несколько секунд пока выполняется инсталляция. Сам процес установки программы автором максимально упрощен но на некоторых моментах уместно остановиться подробнее. Имеется ввиду установка Базовых компонентов программного комплекса.
Для работы программы необходимо обязательное наличие сервера данных FireBird. Единственная проблема, которая может возникнуть, это если уже установлен InterBase. Поскольку у серверов FireBird и InterBase ноги растут из одного и того же места, - оба одновременно они работать не смогут (вернее - специалисты могут это сделать, но лучше установить программу на ПК, где InterBase не установлен). Если уже установлен FireBird, но версии ниже, чем указанная, достаточно выполнить его деинсталляцию и установить версию 2.1.3. В процессе установки FireBird нужно будет дать ответ на несколько вопросов (разных, в зависимосты от Вашей ОС), но там сама инсталляция предлагает довольно оптимальные варианты, т.е. пользователю достаточно просто нажимать "Далее", "Ok" и пр.

Следующие базовые компоненты:

- IB Expert;

- универсальный движок доступа к данным (BDE), сохраненным в других форматах (например Visual FoxPro чи Access);

- драйвер таблиц Visual FoxPro;

- просмотрщик файлов формата fp3 и fp4

в отличие от FireBird не есть обязательными и, как правило, нужны только Админам для просмотра даных в формате dBase III-Plus и для импорта данных из этих таблиц в базу.

Примечание: если сервер FireBird уже установлен, этот шаг будет пропущен вообще. Установку дополнительного ПО можно по желанию будет выполнить после запуска СО через главное меню Сервис - Setup Common.

Будьте внимательны, если СО уже была установлена раньше, файл C:\Program Files\SO3\Data\so.fdb будет перезаписан. Что бы не потерять важные данные, нужно перед инсталляцией перенести его в другую папку или просто переименовать. При условии совместимости (версии два и три несовместимы), данные из предварительно сохраненной базы (все или частично) можно будет по желанию импортировать в новую базу.